我是靠谱客的博主 冷酷猎豹,最近开发中收集的这篇文章主要介绍概率dp HDU 4336 Card CollectorCard Collector,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Card Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1980    Accepted Submission(s): 925
Special Judge


Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award. 

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
 

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks. 

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
 

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
 

Sample Input
1 0.1 2 0.1 0.4
 

Sample Output
10.000 10.500
 

Source
2012 Multi-University Training Contest 4
 

Recommend
zhoujiaqi2010   |   We have carefully selected several similar problems for you:   4337  4331  4332  4333  4334 


题意:你想要收起N个不同的卡片,给出每一次获得某卡片的概率,然后要求要集齐所有卡片的期望次数。

思路:卡片种类最多20种,第一时间想到用状态压缩来表示卡片的获得情况,1代表已经有了,0代表还没有,我们用dp[s] 表示从s到集齐的期望步数,那么dp[s] = sigma(dp[t]*p[j])+sigma(dp[s]*p[j])+1;  然后我们只要分开状态不变的系数和状态转移的系数,那么就可以直接算出dp[s]

代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
#define eps 1e-9
const int maxn = 1<<21;
double p[22];
double f[maxn];
int n;
void init()
{
memset(f,0,sizeof(f));
}
void input()
{
for (int i = 0 ; i < n ; ++i) scanf("%lf",p+i);
}
void solve()
{
double pp;
for (int s = (1<<n)-2 ; s >= 0 ; --s)
{
pp = 0;
for (int j = 0 ; j < n ; ++j)
{
if (s&(1<<j)) continue;
int t = s+(1<<j);
f[s] += p[j]*f[t];
pp += p[j];
}
f[s] = (f[s]+1)/pp;
}
printf("%lfn",f[0]);
}
int main()
{
while (scanf("%d",&n)==1)
{
init();
input();
solve();
}
}

最后

以上就是冷酷猎豹为你收集整理的概率dp HDU 4336 Card CollectorCard Collector的全部内容,希望文章能够帮你解决概率dp HDU 4336 Card CollectorCard Collector所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(41)

评论列表共有 0 条评论

立即
投稿
返回
顶部