我是靠谱客的博主 想人陪往事,最近开发中收集的这篇文章主要介绍HDU 4336 Card Collector(动态规划-概率DP) Card Collector,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Card Collector

Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award. 

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
 

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks. 

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
 

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
 

Sample Input
  
  
1 0.1 2 0.1 0.4
 

Sample Output
  
  
10.000 10.500
 

Source
2012 Multi-University Training Contest 4
 

Recommend
zhoujiaqi2010
 

题目大意:

有n个卡片,你现在买一包方便面,没包方便面出现其中一个卡片的概率为 p[i] ,问你集齐一套卡片需要的张数的数学期望。


解题思路:

概率DP,用位进制0表示这个卡片有了,1表示这个卡片还没有,那么 例如 “3” 用二进制表示 “1 1” 那么 数组 dp[3] 记录的就是 1号卡片和2号卡片都有的情况集齐一套卡片需要的张数的数学期望。

dp[sum]= ( 1+sum { dp[ sum + (1<<j )] *p[j] }   ) /sum{p[j] }

其中 ( i&(1<<j) )==0


解题代码:

#include <iostream>
#include <cstdio>
using namespace std;

const int maxn=(1<<20)+10;
int n;
double dp[maxn];
double p[30];

void solve(){
    int sum=(1<<n)-1;
    dp[sum]=0;
    for(int i=sum-1;i>=0;i--){
        double tmp=0;
        dp[i]=1;
        for(int j=0;j<n;j++){
            if( ( i&(1<<j) )==0 ){
                dp[i]+=dp[i+(1<<j)]*p[j];
                tmp+=p[j];
            }
        }
        dp[i]/=tmp;
    }
    printf("%lfn",dp[0]);
}

int main(){
    while(scanf("%d",&n)!=EOF){
        for(int i=0;i<n;i++) scanf("%lf",&p[i]);
        solve();
    }
    return 0;
}





最后

以上就是想人陪往事为你收集整理的HDU 4336 Card Collector(动态规划-概率DP) Card Collector的全部内容,希望文章能够帮你解决HDU 4336 Card Collector(动态规划-概率DP) Card Collector所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(49)

评论列表共有 0 条评论

立即
投稿
返回
顶部