我是靠谱客的博主 故意小蝴蝶,最近开发中收集的这篇文章主要介绍V - Card Collector (概率dp) In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.  ,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award. 

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks. 

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards. 

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
Sample Input
1
0.1
2
0.1 0.4
Sample Output
10.000
10.500


题意:

有N(1<=N<=20)张卡片,每包中含有这些卡片的概率为p1,p2,````pN.每包至多一张卡片,可能没有卡片。求需要买多少包才能拿到所以的N张卡片,求次数的期望。
思路:

概率dp,第一次接触,不是太熟。看的题解。。。
代码:

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include<iostream>
using namespace std;
double a[25],dp[1<<25];
void solve(int T)
{
int maxx=(1<<T)-1;
dp[0]=0;
for(int i=1; i<=maxx; i++)
{
double tmp=0;
dp[i]=1;
//当前状态一定会成功1*P/P
for(int j=0; j<T; j++)
{
if((1<<j)&i)
//找到1位
{
dp[i]+=dp[i-(1<<j)]*a[j];
//计算前项期望*转移概率
tmp+=a[j];
//计算概率和
}
}
dp[i]/=tmp;
}
printf("%lfn",dp[maxx]);
}
int main()
{
int T;
while(~scanf("%d",&T))
{
for(int i=0; i<T; i++)
scanf("%lf",a+i);
solve(T);
}
return 0;
}


最后

以上就是故意小蝴蝶为你收集整理的V - Card Collector (概率dp) In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.  的全部内容,希望文章能够帮你解决V - Card Collector (概率dp) In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.  所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(52)

评论列表共有 0 条评论

立即
投稿
返回
顶部