我是靠谱客的博主 自由水池,最近开发中收集的这篇文章主要介绍[ACMcoder] Let the Balloon Rise,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink

解题思路

实现代码

#include <iostream>
#include <string>
#include <unordered_map>
using namespace std;

int main()
{
    int n;
    string color;
    while (cin>>n)
    {
        if (n == 0) break;
        unordered_map<string, int> colormap;
        while (n--)
        {
            cin>>color;
            colormap[color]++;
        }

        int max = 0;
        int count;
        string popColor;
        for (auto it = colormap.begin(); it != colormap.end(); it++)
        {
            count = it->second;
            if (count > max)
            {
                max = count;
                popColor = it->first;
            }
        }
        cout<<popColor.c_str()<<endl;
    }
}

最后

以上就是自由水池为你收集整理的[ACMcoder] Let the Balloon Rise的全部内容,希望文章能够帮你解决[ACMcoder] Let the Balloon Rise所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(55)

评论列表共有 0 条评论

立即
投稿
返回
顶部