题目
Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N ( 0 < N < = 1000 ) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink
代码块
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner cn = new Scanner(System.in);
while(cn.hasNext()){
int n = cn.nextInt();
if(n==0) return;
Color[] co = new Color[n];
for(int i =0;i<n;i++){
String str = cn.next();
co[i] = new Color(str,0);
}
for(int i =0;i<n-1;i++){
for(int j =i;j<n;j++){
if(co[i].getName().equals(co[j].getName())){
int z = co[i].getMath();
co[i].setMath(++z);
}
}
}
int max = co[0].getMath();
for(int i =0;i<n;i++){
if(max<co[i].getMath()){
max = co[i].getMath();
}
}
for(int i =0;i<n;i++){
if(co[i].getMath()==max){
System.out.println(co[i].getName());
break;
}
}
}
}
}
class Color{
private String name;
private int math;
public Color(String name, int math) {
super();
this.name = name;
this.math = math;
}
public String getName() {
return name;
}
public void setName(String name) {
this.name = name;
}
public int getMath() {
return math;
}
public void setMath(int math) {
this.math = math;
}
}
最后
以上就是文艺老鼠最近收集整理的关于1248: Let the Balloon Rise的全部内容,更多相关1248:内容请搜索靠谱客的其他文章。
发表评论 取消回复