我是靠谱客的博主 单身柚子,最近开发中收集的这篇文章主要介绍Hdu1004(map)java,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

代码:

//package util;
import java.util.Stack;
import java.util.HashMap;
import java.util.Scanner;
public class Main{
public static void main(String []args) {
Scanner sc = new Scanner(System.in);
HashMap <String,Integer>mp = new HashMap<String, Integer>();
while(sc.hasNext())
{
int n = sc.nextInt();
if (n == 0) break;
String s;
mp.clear();
for(int i = 1;i <= n ;i++) {
s = sc.next();
if(mp.containsKey(s) == false)
{
mp.put(s,new Integer(1));
}else
mp.put(s,new Integer(mp.get(s).intValue()+1));
}
int maxn = 0;
String last="";
for(String gg :mp.keySet()) {
if(mp.get(gg).intValue() > maxn) {
maxn = mp.get(gg).intValue();
last = gg;
}
}
System.out.println(last);
}
sc.close();
}
}

 

最后

以上就是单身柚子为你收集整理的Hdu1004(map)java的全部内容,希望文章能够帮你解决Hdu1004(map)java所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(57)

评论列表共有 0 条评论

立即
投稿
返回
顶部