概述
Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
Give you a letter x and a number y , you should output the result of y+f(x).
Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
Output
for each case, you should the result of y+f(x) on a line.
Sample Input
6R 1P 2G 3r 1p 2g 3
Sample Output
191810-17-14
-4
- #include<iostream>
- using namespace std;
- int main()
- {
- int m,n,b[1000],i;
- char ch;
- b['a']=-1;
- for(i='b';i<='z';i++)
- b[i]=b[i-1]-1;
- cin>>n;
- while(n--)
- {
- cin>>ch>>m;
- if(ch>='a'&&ch<='z')
- cout<<b[ch]+m<<endl;
- else
- cout<<-b[ch+32]+m<<endl;
- }
- return 0;
- }
最后
以上就是年轻翅膀为你收集整理的HDU-2055 An easy problem的全部内容,希望文章能够帮你解决HDU-2055 An easy problem所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复