我是靠谱客的博主 机灵灰狼,最近开发中收集的这篇文章主要介绍HDOJ 2055 An easy problem,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description

we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, … f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).

Input

On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

Output

for each case, you should the result of y+f(x) on a line.

Sample Input

6
R 1
P 2
G 3
r 1
p 2
g 3

Sample Output

19
18
10
-17
-14
-4

题如其名,没意思的一个题,做法可以有很多,就看怎么选择了。
我就是直接输入的字母 x -(A 或 a) + 1 ,然后加 y 就是结果了。
暴力一点就直接把26个大小写字母放入数组,一个一个填好,然后直接调用就行。

#include<iostream>

using namespace std;

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int y,sum=0;
        char x;
        cin>>x>>y;
        if(x>='A'&&x<='Z')
            sum=y+1+x-'A';
        else if(x>='a'&&x<='z')
            sum=y-(x-'a'+1);
        cout<<sum<<endl;
    }
}

最后

以上就是机灵灰狼为你收集整理的HDOJ 2055 An easy problem的全部内容,希望文章能够帮你解决HDOJ 2055 An easy problem所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(47)

评论列表共有 0 条评论

立即
投稿
返回
顶部