我是靠谱客的博主 聪慧鸵鸟,最近开发中收集的这篇文章主要介绍1005(三维树状数组+区间更新,单点求值),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description
Given an N*N*N cube A, whose elements are either 0 or 1. A[i, j, k] means the number in the i-th row , j-th column and k-th layer. Initially we have A[i, j, k] = 0 (1 <= i, j, k <= N).
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].

Input
Multi-cases. First line contains N and M, M lines follow indicating the operation below. Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation. If X is 1, following x1, y1, z1, x2, y2, z2. If X is 0, following x, y, z.

Output
For each query output A[x, y, z] in one line. (1<=n<=100 sum of m <=10000)

Sample Input
  
  
2 5 1 1 1 1 1 1 1 0 1 1 1 1 1 1 1 2 2 2 0 1 1 1 0 2 2 2

Sample Output
  
  
1 0 1

题目大概+思路:

区间更新,单点求和的三维树状数组的模板题。
不过三维的想起来有点麻烦,需要好多加加减减。具体的看代码。

代码:


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

int n;
long long c[102][102][102];

int vis[102][102][102];
int lowbit(int x)
{
    return x&(-x);
}
void add(int x,int y,int z,int v)
{ for(int k=z;k<=101;k+=lowbit(k))
    for(int i=x;i<=101;i+=lowbit(i))
    {
        for(int j=y;j<=101;j+=lowbit(j))
        c[k][i][j]+=v;

    }
}

long long sum(int x,int y,int z)
{
    long long su=0;
    for(int k=z;k>0;k-=lowbit(k))
    for(int i=x;i>0;i-=lowbit(i))
    {
        for(int j=y;j>0;j-=lowbit(j))
        su+=c[k][i][j];

    }
    return su;
}
int main()
{
int n,m;
    while(~scanf("%d%d",&n,&m))
    {

        memset(vis,0,sizeof(vis));
        memset(c,0,sizeof(c));

        while(m--)
        {
            int gg;
             scanf("%d",&gg);

             if(gg==1)
             {
                 int w1,w2,w3,e1,e2,e3;
                  scanf("%d%d%d%d%d%d",&w1,&w2,&w3,&e1,&e2,&e3);
                  add(w1,w2,w3,1);
                  add(e1+1,e2+1,e3+1,-1);
                  add(w1,w2,e3+1,-1);
                  add(e1+1,w2,w3,-1);
                  add(e1+1,w2,e3+1,1);
                  add(w1,e2+1,w3,-1);
                  add(w1,e2+1,e3+1,1);
                  add(e1+1,e2+1,w3,1);
    
             }
             else if(gg==0)
             {
                 int r1,r2,r3;
                 scanf("%d%d%d",&r1,&r2,&r3);
                 long long sun=0;
                 sun=sum(r1,r2,r3);
                 int k=0;

                 if(sun%2==0)k=0;
                 else k=1;
                 printf("%dn",k);
             }

        }


    }





    return 0;
}




最后

以上就是聪慧鸵鸟为你收集整理的1005(三维树状数组+区间更新,单点求值)的全部内容,希望文章能够帮你解决1005(三维树状数组+区间更新,单点求值)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(51)

评论列表共有 0 条评论

立即
投稿
返回
顶部