概述
Cube
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)Total Submission(s): 1437 Accepted Submission(s): 741
Problem Description
Given an N*N*N cube A, whose elements are either 0 or 1. A[i, j, k] means the number in the i-th row , j-th column and k-th layer. Initially we have A[i, j, k] = 0 (1 <= i, j, k <= N).
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].
Input
Multi-cases.
First line contains N and M, M lines follow indicating the operation below.
Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation.
If X is 1, following x1, y1, z1, x2, y2, z2.
If X is 0, following x, y, z.
First line contains N and M, M lines follow indicating the operation below.
Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation.
If X is 1, following x1, y1, z1, x2, y2, z2.
If X is 0, following x, y, z.
Output
For each query output A[x, y, z] in one line. (1<=n<=100 sum of m <=10000)
Sample Input
2 5 1 1 1 1 1 1 1 0 1 1 1 1 1 1 1 2 2 2 0 1 1 1 0 2 2 2
Sample Output
1 0 1
Author
alpc32
Source
2010 ACM-ICPC Multi-University Training Contest(15)——Host by NUDT
Recommend
zhouzeyong | We have carefully selected several similar problems for you: 1166 3450 1541 1394 1892
题意,n*n*n的矩阵,值为0 或者1 ,“1”操作改变(x1,y1,z1)到(x2,y2,z2)内的所有点,“0”操作问(x,y,z)的值,也就是统计改变的次数
同一维,二维一样,定义一个数组a,a[i][j][j]表示(i,j,k)到(n,n,n)的矩形中每个点都改编a[i][j][k]次,对于(x1,y1,z1)到(x2,y2,z2)的矩形改变1次,可以转化为a[x1][y1][z1] += 1,还要把多加的删去(如a(x1,y1,z1+1) += -1 等),最后保证仅对(x1,y1,z1)到(x2,y2,z2)改变
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int c[110][110][110] ;
int lowbit(int x)
{
return x & -x ;
}
int add(int i,int j,int k,int n,int d)
{
int x , y , z ;
for(x = i ; x <= n ; x += lowbit(x))
for(y = j ; y <= n ; y += lowbit(y))
for(z = k ; z <= n ; z += lowbit(z))
c[x][y][z] += d ;
}
int sum(int i,int j,int k)
{
int a = 0 , x , y , z ;
for(x = i ; x > 0 ; x -= lowbit(x))
for(y = j ; y > 0 ; y -= lowbit(y))
for(z = k ; z > 0 ; z -= lowbit(z))
a += c[x][y][z];
return a ;
}
int main()
{
int k , n , m , x , y , z ;
while(scanf("%d %d", &n, &m) != EOF)
{
memset(c,0,sizeof(c));
while(m--)
{
scanf("%d %d %d %d", &k, &x, &y, &z);
if(k == 0)
{
printf("%dn", sum(x,y,z)%2);
}
else
{
int x1 , y1 , z1 ;
scanf("%d %d %d", &x1, &y1, &z1);
add(x,y,z,n,1);
add(x1+1,y,z,n,-1);
add(x,y1+1,z,n,-1);
add(x,y,z1+1,n,-1);
add(x1+1,y1+1,z,n,1);
add(x1+1,y,z1+1,n,1);
add(x,y1+1,z1+1,n,1);
add(x1+1,y1+1,z1+1,n,-1);
}
}
}
return 0;
}
最后
以上就是自由发带为你收集整理的hdu3584--Cube(三维树状数组)Cube的全部内容,希望文章能够帮你解决hdu3584--Cube(三维树状数组)Cube所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复