我是靠谱客的博主 呆萌小蝴蝶,最近开发中收集的这篇文章主要介绍HDU - 3584 - Cube (树状数组+容斥) Cube,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 2383    Accepted Submission(s): 1219


Problem Description
Given an N*N*N cube A, whose elements are either 0 or 1. A[i, j, k] means the number in the i-th row , j-th column and k-th layer. Initially we have A[i, j, k] = 0 (1 <= i, j, k <= N). 
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].
 

Input
Multi-cases.
First line contains N and M, M lines follow indicating the operation below.
Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation.
If X is 1, following x1, y1, z1, x2, y2, z2.
If X is 0, following x, y, z.
 

Output
For each query output A[x, y, z] in one line. (1<=n<=100 sum of m <=10000)
 

Sample Input
  
  
2 5 1 1 1 1 1 1 1 0 1 1 1 1 1 1 1 2 2 2 0 1 1 1 0 2 2 2
 

Sample Output
  
  
1 0 1
 

Author
alpc32
 

Source
2010 ACM-ICPC Multi-University Training Contest(15)——Host by NUDT 
 



题意:有一个三维直角坐标系,其中每个点都有值(0或1),刚开始均为0,有两种操作,Not和Query,分别代表将(x1,y1,z1)到(x2,y2,z2)中的点全部取反,和询问点(x,y,z)的值

思路:三维树状数组,容斥原理,取反两次即为不取反




#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;

int lowbit(int x){return x&(-x);}

const int maxn= 100+5;

int n,m,sum[maxn][maxn][maxn];

int x1,x2,y1,y2,z1,z2,ope;

void add(int x,int y,int z)
{
    for(int i=x;i<=n;i+=lowbit(i))
        for(int j=y;j<=n;j+=lowbit(j))
            for(int k=z;k<=n;k+=lowbit(k))
                sum[i][j][k]++;
}

int query(int x,int y,int z)
{
    int ans = 0;
    for(int i=x;i>0;i-=lowbit(i))
        for(int j=y;j>0;j-=lowbit(j))
            for(int k=z;k>0;k-=lowbit(k))
                ans+=sum[i][j][k];
    return ans;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF){
        memset(sum,0,sizeof sum);
        while(m--){
            scanf("%d",&ope);
            if(ope==1){
                scanf("%d%d%d%d%d%d",&x1,&y1,&z1,&x2,&y2,&z2);
                add(x1, y1, z1);
                add(x2+1, y1, z1);
                add(x1, y2+1, z1);
                add(x1, y1, z2+1);
                add(x2+1, y2+1, z1);
                add(x2+1, y1, z2+1);
                add(x1, y2+1, z2+1);
                add(x2+1, y2+1, z2+1);
                
            }else{
                scanf("%d%d%d",&x1,&y1,&z1);
                printf("%dn",query(x1, y1, z1)%2);
            }
        }
    }
    return 0;
}



最后

以上就是呆萌小蝴蝶为你收集整理的HDU - 3584 - Cube (树状数组+容斥) Cube的全部内容,希望文章能够帮你解决HDU - 3584 - Cube (树状数组+容斥) Cube所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(43)

评论列表共有 0 条评论

立即
投稿
返回
顶部