概述
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
这是很经典的题,大数加法,先输入两个字符串,然后将两个字符串分别逆序存储到两个整型数组里面,然后去掉前置零,再用另外一个整型数组,来计算最后的结果。
#include<stdio.h>
#include<string.h>
int main()
{
int n,w=1,m;
scanf("%d",&n);
m=n;
while(n--)
{
int u=0;
char a[1010],b[1010];
scanf("%s%s",a,b);
int l1=strlen(a);
int l2=strlen(b);
int x[1010],y[1010],z[1010];
memset(x,0,sizeof(x));
memset(y,0,sizeof(y));
memset(z,0,sizeof(z));
for(int i=l1-1,k=0; i>=0; i--,k++)
x[k]=a[i]-'0';
for(int i=l2-1,k=0; i>=0; i--,k++)
y[k]=b[i]-'0';
int l3=l1>l2?l1:l2;
for(int i=0; i<=l3; i++)
{
z[i]=x[i]+y[i]+u;
u=z[i]/10;
z[i]=z[i]%10;
}
for(int i=l3; i>=0; i--)
if(z[i]!=0)
{
l3=i;
break;
}
printf("Case %d:n%s + %s = ",w++,a,b);
for(int i=l3; i>=0; i--)
{
printf("%d",z[i]);
}
printf("n");
if(w<=m)
printf("n");
}
return 0;
}
最后
以上就是曾经往事为你收集整理的A + B Problem II的全部内容,希望文章能够帮你解决A + B Problem II所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复