我是靠谱客的博主 朴实果汁,最近开发中收集的这篇文章主要介绍2016 ccpc长春现场赛I Sequence I(hdu 5918) Sequence I,觉得挺不错的,现在分享给大家,希望可以做个参考。
概述
Sequence I
Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 0 Accepted Submission(s): 0
Problem Description
Mr. Frog has two sequences
a1,a2,⋯,an
and
b1,b2,⋯,bm
and a number p. He wants to know the number of positions q such that sequence
b1,b2,⋯,bm
is exactly the sequence
aq,aq+p,aq+2p,⋯,aq+(m−1)p
where
q+(m−1)p≤n
and
q≥1
.
Input
The first line contains only one integer
T≤100
, which indicates the number of test cases.
Each test case contains three lines.
The first line contains three space-separated integers 1≤n≤106,1≤m≤106 and 1≤p≤106 .
The second line contains n integers a1,a2,⋯,an(1≤ai≤109) .
the third line contains m integers b1,b2,⋯,bm(1≤bi≤109) .
Each test case contains three lines.
The first line contains three space-separated integers 1≤n≤106,1≤m≤106 and 1≤p≤106 .
The second line contains n integers a1,a2,⋯,an(1≤ai≤109) .
the third line contains m integers b1,b2,⋯,bm(1≤bi≤109) .
Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
Sample Input
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
Sample Output
Case #1: 2 Case #2: 1
思路:现场赛的时候这道题可以暴力O(n*m)过的,但估计这道题想考的是kmp,把kmp模板改一下就好了,kmp的时间复杂度是O(n),别问我为什么暴力比kmp速度更快。下面给代码
#include<set>
#include<map>
#include<ctime>
#include<cmath>
#include<stack>
#include<queue>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
typedef long long LL;
using namespace std;
#define inf 0x3f3f3f3f
#define maxn 100005
typedef long long LL;
int num, sum, n, m;
int next1[maxn], P[maxn], T[maxn];
void makeNext()
{
int q, k;
next1[0] = 0;
for (q = 1, k = 0; q < m; ++q)
{
while (k > 0 && P[q] != P[k])
k = next1[k - 1];
if (P[q] == P[k])
{
k++;
}
next1[q] = k;
}
}
void kmp()
{
int i, q;
makeNext();
for (int st = 0; st < num; st++){
for (i = st, q = 0; i < n; i += num)
{
while (q > 0 && P[q] != T[i])
q = next1[q - 1];
if (P[q] == T[i])
{
q++;
}
if (q == m)
{
sum++;
}
}
}
}
int main(){
int t;
scanf("%d", &t);
for (int tcase = 1; tcase <= t; tcase++){
memset(P, 0, sizeof(P));
memset(T, 0, sizeof(T));
scanf("%d%d%d", &n, &m, &num);
for (int i = 0; i<n; i++){
scanf("%d", &T[i]);
}
for (int i = 0; i<m; i++){
scanf("%d", &P[i]);
}
sum = 0;
kmp();
printf("Case #%d: %dn", tcase, sum);
}
}
最后
以上就是朴实果汁为你收集整理的2016 ccpc长春现场赛I Sequence I(hdu 5918) Sequence I的全部内容,希望文章能够帮你解决2016 ccpc长春现场赛I Sequence I(hdu 5918) Sequence I所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复