概述
Sequence I
Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 862 Accepted Submission(s): 332
Problem Description
Mr. Frog has two sequences
a1,a2,⋯,an
and
b1,b2,⋯,bm
and a number p. He wants to know the number of positions q such that sequence
b1,b2,⋯,bm
is exactly the sequence
aq,aq+p,aq+2p,⋯,aq+(m−1)p
where
q+(m−1)p≤n
and
q≥1
.
Input
The first line contains only one integer
T≤100
, which indicates the number of test cases.
Each test case contains three lines.
The first line contains three space-separated integers 1≤n≤106,1≤m≤106 and 1≤p≤106 .
The second line contains n integers a1,a2,⋯,an(1≤ai≤109) .
the third line contains m integers b1,b2,⋯,bm(1≤bi≤109) .
Each test case contains three lines.
The first line contains three space-separated integers 1≤n≤106,1≤m≤106 and 1≤p≤106 .
The second line contains n integers a1,a2,⋯,an(1≤ai≤109) .
the third line contains m integers b1,b2,⋯,bm(1≤bi≤109) .
Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
Sample Input
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
Sample Output
Case #1: 2 Case #2: 1
Source
2016中国大学生程序设计竞赛(长春)-重现赛
题意:给两个序列和一个步长,问其中一个序列是否可以在确定步长的情况下构造一个完全匹配另一个序列的子序列,如果可以统计起始位置有多少个。
思路:一开始听了zy1的思路说要用KMP,然后我就敲完模板发现自己还是不会用KMP,后来又读了一遍题,发现我都构造出来了直接判断相等就可以了..不过如果用KMP的话应该就不用提前构造了吧。
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
using namespace std;
int n,m;
int a[100005];
int b;
int main(){
int t;
scanf("%d",&t);
for(int cas=1;cas<=t;cas++){
int q;
scanf("%d %d %d",&n,&m,&q);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
string str="";
for(int i=0;i<m;i++){
scanf("%d",&b);
str+=(b+'0');
}
int ans=0;
for(int i=0;i+(m-1)*q<n;i++){
string s="";
for(int j=i;j<=i+(m-1)*q;j+=q){
s+=(a[j]+'0');
}
if(str==s)
ans++;
}
printf("Case #%d: %dn",cas,ans);
}
return 0;
}
最后
以上就是俏皮大叔为你收集整理的HDU 5918 Sequence I (水题+字符串匹配)Sequence I的全部内容,希望文章能够帮你解决HDU 5918 Sequence I (水题+字符串匹配)Sequence I所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复