我是靠谱客的博主 清爽柚子,最近开发中收集的这篇文章主要介绍POJ题目2282 The Counting Problem(数学),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

The Counting Problem
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 3559 Accepted: 1890

Description

Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit. For example, if a = 1024 and b = 1032, the list will be 
1024 1025 1026 1027 1028 1029 1030 1031 1032

there are ten 0's in the list, ten 1's, seven 2's, three 3's, and etc.

Input

The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line `0 0', which is not considered as part of the input.

Output

For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc.

Sample Input

1 10
44 497
346 542
1199 1748
1496 1403
1004 503
1714 190
1317 854
1976 494
1001 1960
0 0

Sample Output

1 2 1 1 1 1 1 1 1 1
85 185 185 185 190 96 96 96 95 93
40 40 40 93 136 82 40 40 40 40
115 666 215 215 214 205 205 154 105 106
16 113 19 20 114 20 20 19 19 16
107 105 100 101 101 197 200 200 200 200
413 1133 503 503 503 502 502 417 402 412
196 512 186 104 87 93 97 97 142 196
398 1375 398 398 405 499 499 495 488 471
294 1256 296 296 296 296 287 286 286 247

Source

Shanghai 2004
题目大意:输入两个数a,b,求a~b之间所有数0~9出现的次数
ac代码
#include<stdio.h>
#include<string.h>
int ansa[20],ansb[20];
void dfs(int n,int *ans,int t)
{
	int i,a,b;
	if(n<=0)
		return;
	a=n%10;
	b=n/10;
	for(i=1;i<=a;i++)
		ans[i]+=t;
	while(b)
	{
		ans[b%10]+=t*(a+1);
		b/=10;
	}
	for(i=0;i<=9;i++)
		ans[i]+=t*(n/10);
	t*=10;
	dfs((n/10)-1,ans,t);
}
int main()
{
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF,a||b)
	{
		int i;
		if(a>=b)
		{
			int t=a;
			a=b;
			b=t;
		}
		memset(ansa,0,sizeof(ansa));
		memset(ansb,0,sizeof(ansb));
		a--;
		if(b>a)
		{
			dfs(a,ansa,1);
			dfs(b,ansb,1);
		}
		for(i=0;i<=9;i++)
		{
			if(i)
				printf(" %d",ansb[i]-ansa[i]);
			else
				printf("%d",ansb[i]-ansa[i]);
		}
		printf("n");
	}
}


最后

以上就是清爽柚子为你收集整理的POJ题目2282 The Counting Problem(数学)的全部内容,希望文章能够帮你解决POJ题目2282 The Counting Problem(数学)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(60)

评论列表共有 0 条评论

立即
投稿
返回
顶部