我是靠谱客的博主 丰富外套,最近开发中收集的这篇文章主要介绍LCM Walk HDU - 5584(数论+思维)LCM Walk HDU - 5584,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

LCM Walk HDU - 5584

A frog has just learned some number theory, and can’t wait to show his ability to his girlfriend.

Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered 1,2,⋯ from the bottom, so are the columns. At first the frog is sitting at grid (sx,sy), and begins his journey.

To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid (x,y), first of all, he will find the minimum z that can be divided by both x and y, and jump exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y), or (x,y+z).

After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey). However, he is too tired and he forgets the position of his starting grid!

It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach (ex,ey)
!
Input
First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers ex and ey, which is the destination grid.

⋅ 1≤T≤1000.
⋅ 1≤ex,ey≤109
.
Output
For every test case, you should output ” Case #x: y”, where x indicates the case number and counts from 1 and y
is the number of possible starting grids.
Sample Input

3
6 10
6 8
2 8

Sample Output

Case #1: 1
Case #2: 2
Case #3: 3

题意:

给定在某个坐标 (x,y) ( x , y ) 的移动规则:

从点 (x,y)(x+lcm(x,y),y)(x,y+lcm(x,y)) ( x , y ) 只 能 移 动 到 ( x + l c m ( x , y ) , y ) 或 ( x , y + l c m ( x , y ) )

给定终点 (ex,ey) ( e x , e y ) 问有多少起点能够到达这个终点(坐标大于0)

分析:

根据题意从点

(x,y)(x,y+lcm(x,y)) ( x , y ) → ( x , y + l c m ( x , y ) )

lcm(x,y)=xygcd(x,y) ∵ l c m ( x , y ) = x y g c d ( x , y )

gcd(x,y)=g,x=m1g,y=m2g g c d ( x , y ) = g , 则 x = m 1 g , y = m 2 g

lcm(x,y)=m1m2g2g=m1m2g ∴ l c m ( x , y ) = m 1 m 2 g 2 g = m 1 m 2 g

(x,y)(x,y+lcm(x,y)) ( x , y ) → ( x , y + l c m ( x , y ) )

(m1g,m2g)(m1g,m2g+m1m2g) ( m 1 g , m 2 g ) → ( m 1 g , m 2 g + m 1 m 2 g )

(m1g,m2g)(m1g,m2g(1+m1)) ( m 1 g , m 2 g ) → ( m 1 g , m 2 g ⋅ ( 1 + m 1 ) )

m1,m2,m1,m1+1 ∵ m 1 , m 2 互 质 , m 1 , m 1 + 1 互 质

转移到新坐标后,横纵坐标的最大公因数仍然是g

因此我们发现对于给定的终点 (ex,ey) ( e x , e y ) ,可以到达这个终点的路径上的所有点坐标的横纵坐标最大公因数恒为 g g ,并且前后必定满足式子

(m1g,m2g)(m1g,m2g(1+m1))

所以我们只需要根据终点逆推回去就行了,对于到达位置的坐标,上式中纵坐标始终是较大的值,所以每次,我们只需要交换顺序,使得后者始终较大即可

那么什么时候终止呢?

仍然是观察上面前后坐标的关系

如果存在前一个坐标,当前坐标必然满足

(m1g,m2g(1+m1))=(m1g,m2(g+m1g)) ( m 1 g , m 2 g ⋅ ( 1 + m 1 ) ) = ( m 1 g , m 2 ⋅ ( g + m 1 g ) )

所以较大坐标内含有因子 (g+m1g) ( g + m 1 g ) ,因此我们只需要取模判断一下即可

gm1,m1m2 知 道 了 终 点 坐 标 , 首 先 我 们 可 以 求 出 最 大 公 因 数 g , 然 后 也 就 求 出 了 m 1 , 有 了 m 1 也 就 可 以 求 出 了 m 2

又一个当时没做出来的数论题mlgb

code:

#include <bits/stdc++.h>
using namespace std;
int gcd(int a,int b){
return b ? gcd(b,a%b) : a;
}
int main(){
int T,cas = 0;
scanf("%d",&T);
int x,y;
while(T--){
scanf("%d%d",&x,&y);
int ans = 1;//终点也算一个
int m1,m2;
int g = gcd(x,y);
if(x > y) swap(x,y);
while(y % (x + g) == 0){
ans++;
x = x;
y = y / (g + x) * g;
if(x > y) swap(x,y);
}
printf("Case #%d: %dn",++cas,ans);
}
return 0;
}

最后

以上就是丰富外套为你收集整理的LCM Walk HDU - 5584(数论+思维)LCM Walk HDU - 5584的全部内容,希望文章能够帮你解决LCM Walk HDU - 5584(数论+思维)LCM Walk HDU - 5584所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(47)

评论列表共有 0 条评论

立即
投稿
返回
顶部