我是靠谱客的博主 友好戒指,最近开发中收集的这篇文章主要介绍HDU 5584 LCM Walk(逆推)——2015ACM/ICPC亚洲区上海站 LCM Walk,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

LCM Walk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
A frog has just learned some number theory, and can't wait to show his ability to his girlfriend.

Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered  1,2,  from the bottom, so are the columns. At first the frog is sitting at grid  (sx,sy) , and begins his journey.

To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid  (x,y) , first of all, he will find the minimum  z  that can be divided by both  x  and  y , and jump exactly  z  steps to the up, or to the right. So the next possible grid will be  (x+z,y) , or  (x,y+z) .

After a finite number of steps (perhaps zero), he finally finishes at grid  (ex,ey) . However, he is too tired and he forgets the position of his starting grid!

It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach  (ex,ey) !
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test case contains two integers  ex  and  ey , which is the destination grid.

  1T1000 .
  1ex,ey109 .
 

Output
For every test case, you should output " Case #x: y", where  x  indicates the case number and counts from  1  and  y  is the number of possible starting grids.
 

Sample Input
  
  
3 6 10 6 8 2 8
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 3
 
/*********************************************************************/

题意:有一只青蛙,它从起点(x,y)出发,每次它会走LCM(x,y)步[LCM(x,y)就是x,y的最小公倍数]到达点(x+LCM(x,y),y)或点(x,y+LCM(x,y)),最终,它会到达点(ex,ey),现给你终点(ex,ey),要你求出它的起点有多少种可能

解题思路:我们暂时假设x,y的最大公约数gcd(x,y)=k,那么我们不妨用来表示x,用来表示y,那么新得到的点必定是,因为x与y的最小公倍数

我们不妨求解一下新的点x和y的gcd值,以点为例


因为时互质的,也是互质的,故

所以,我们可以发现先得到的点和原来的点有相同的最大公约数,故我们可以利用这一点来根据终点求解原先的起点

还有一点需要提及的是,对于当前点(x,y),x,y中小的那个值必定是之前那个点中的x值或y值,故我们可以开始逆推了

有不懂的地方欢迎交流

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<cmath>
#include<string>
#include<algorithm>
#include<iostream>
#define exp 1e-10
using namespace std;
const int N = 100005;
const int M = 10005;
const int inf = 1000000000;
const int mod = 10007;
int gcd(int x,int y)
{
    if(x%y)
        return gcd(y,x%y);
    return y;
}
int main()
{
    int t,k,c,p=1,x,y;
    scanf("%d",&t);
    while(t--)
    {
        c=1;
        scanf("%d%d",&x,&y);
        if(x>y)
            swap(x,y);
        k=gcd(x,y);
        while(y%(x+k)==0)
        {
            c++;
            y=y/(x/k+1);
            if(x>y)
                swap(x,y);
            k=gcd(x,y);
        }
        printf("Case #%d: %dn",p++,c);
    }
    return 0;
}
菜鸟成长记

最后

以上就是友好戒指为你收集整理的HDU 5584 LCM Walk(逆推)——2015ACM/ICPC亚洲区上海站 LCM Walk的全部内容,希望文章能够帮你解决HDU 5584 LCM Walk(逆推)——2015ACM/ICPC亚洲区上海站 LCM Walk所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(56)

评论列表共有 0 条评论

立即
投稿
返回
顶部