我是靠谱客的博主 醉熏柜子,最近开发中收集的这篇文章主要介绍HDU-5584 LCM Walk(GCD/LCM+找规律) LCM Walk,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

LCM Walk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1005    Accepted Submission(s): 525


Problem Description
A frog has just learned some number theory, and can't wait to show his ability to his girlfriend.

Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered  1,2,  from the bottom, so are the columns. At first the frog is sitting at grid  (sx,sy) , and begins his journey.

To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid  (x,y) , first of all, he will find the minimum  z  that can be divided by both  x  and  y , and jump exactly  z  steps to the up, or to the right. So the next possible grid will be  (x+z,y) , or  (x,y+z) .

After a finite number of steps (perhaps zero), he finally finishes at grid  (ex,ey) . However, he is too tired and he forgets the position of his starting grid!

It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach  (ex,ey) !
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test case contains two integers  ex  and  ey , which is the destination grid.

  1T1000 .
  1ex,ey109 .
 

Output
For every test case, you should output " Case #x: y", where  x  indicates the case number and counts from  1  and  y  is the number of possible starting grids.
 

Sample Input
3 6 10 6 8 2 8
 

Sample Output
Case #1: 1 Case #2: 2 Case #3: 3
 

Source
2015ACM/ICPC亚洲区上海站-重现赛(感谢华东理工)
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5901  5900  5899  5898  5897 

题意:每次只给出终点坐标(ex,ey),假设当前位置是(x,y),只能向右走或者向下走,下一步只能走到(x+z,y)或者(x,y+z),z=lcm(x,y)  (一开始读错题,以为z只要是lcm(x,y)的倍数就可以),问可以从多少个点出发到达终点

题解:①我们可以发现当前位置是(x,y)时,如果x>y,那么当前位置一定是由(x1,y)走到的,如果x<y,当前位置一定是由(x,y1)走到的,由这点确定了路径的唯一性

②设gcd(x,y)=k,x=nk,y=mk,lcm(x,y)=nmk,那么下一步能走到(n(m+1)k,mk)或者(nk,m(n+1)k),并且由于n(m+1)与m互质,n与m(n+1)互质,所以下一步的gcd依然是k.

③根据以上两点,就可以用逆推找出答案,每次都假设x>y,x=nk,y=mk,当前点就是由(x/(y/k+1),y)走到的,如果x不再是(y+k)的倍数(即:(y/k+1)*k的倍数),则表示不能再逆推

#include<cstdio>
#include<algorithm>
using namespace std;
int gcd(int a,int b){return b?gcd(b,a%b):a;}
int main(){
int x,y,T;
scanf("%d",&T);
for(int cas=1;cas<=T;cas++){
scanf("%d%d",&x,&y);
if(x<y) swap(x,y);
int k=gcd(x,y),cnt=1;
while(x%(y+k)==0){
cnt++;
x=x/(y/k+1);
if(x<y) swap(x,y);
}
printf("Case #%d: %dn",cas,cnt);
}
return 0;
}


最后

以上就是醉熏柜子为你收集整理的HDU-5584 LCM Walk(GCD/LCM+找规律) LCM Walk的全部内容,希望文章能够帮你解决HDU-5584 LCM Walk(GCD/LCM+找规律) LCM Walk所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(38)

评论列表共有 0 条评论

立即
投稿
返回
顶部