我是靠谱客的博主 美满鞋子,最近开发中收集的这篇文章主要介绍hdu3853 LOOPSLOOPS,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

LOOPS

Time Limit: 15000/5000 MS (Java/Others) Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 1343 Accepted Submission(s): 546


Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.





Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF



Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.


Sample Input
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00

Sample Output
6.000
解析:
设dp[i][j]表示(i,j)到(R,C)需要消耗的能量
则:
dp[i][j]=p1[i][j]*dp[i][j]+p2[i][j]*dp[i][j+1]+p3[i][j]*dp[i+1][j]+2;
化简得到:
dp[i][j]=p2[i][j]*dp[i][j+1]/(1-p1[i][j])+p3[i][j]*dp[i+1][j]/(1-p1[i][j])+2/(1-p1[i][j]);
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;
#define M 1005
#define eps 1e-5
double a[M][M],b[M][M],d[M][M],ans[M][M];
int main()
{
int r,c,i,j;
while(scanf("%d%d",&r,&c)!=EOF){
for(i=1;i<=r;i++)
for(j=1;j<=c;j++){
scanf("%lf%lf%lf",&a[i][j],&b[i][j],&d[i][j]);
}
memset(ans,0,sizeof(ans));
for(i=r;i>=1;i--)
for(j=c;j>=1;j--){
if(i==r&&j==c)
continue;
if(fabs(1-a[i][j])<eps)continue;
ans[i][j]=(ans[i][j+1]*b[i][j]+ans[i+1][j]*d[i][j]+2.0)/(1-a[i][j]);
}
printf("%.3fn",ans[1][1]);
}
return 0;
}


最后

以上就是美满鞋子为你收集整理的hdu3853 LOOPSLOOPS的全部内容,希望文章能够帮你解决hdu3853 LOOPSLOOPS所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(50)

评论列表共有 0 条评论

立即
投稿
返回
顶部