我是靠谱客的博主 顺利服饰,最近开发中收集的这篇文章主要介绍[Arrays]D. Liang 6.5 Printing distinct numbers.cDescriptionInputOutputSample InputSample Output,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Description

Write a program that reads in n integers and displays distinct numbers (ie., if a number appears multiple times, it is displayed only once).

Input

The first line is a positive integer t for the number of test cases.
Each test case contains two lines. The first line is an integer n (0<n<=100). The second line contains n integers.

Output

For each test case, outputs the distinct numbers in order in which they were read, seperated by one blank.

Sample Input

2
3
1 2 1
4
2 1 2 1

Sample Output

1 2
2 1
//
Date:2020/4/18
//
Author:xiezhg5 
#include <stdio.h>
int main(void)
{
int m;
scanf("%d",&m);
int a[20][100];
//巧妙定义一个二维数组 
int i,j,num[100];
for(i=0;i<m;i++)
{
scanf("%d",&num[i]);
//把输入的数放在一个新数组中 
for(j=0;j<num[i];j++)
scanf("%d",&a[i][j]);
}
int k;
for(i=0;i<m;i++)
{
printf("%d",a[i][0]);
//输出第一列的数组元素 
for(j=1;j<num[i];j++)
{
for(k=0;k<j;k++)
{
if(a[i][k]==a[i][j]) //元素相同则立即跳出循环 
break;
}
if(k==j)
//如果不同就输出注意次序 
printf(" %d",a[i][j]);
}
printf("n");
}
return 0;
}

最后

以上就是顺利服饰为你收集整理的[Arrays]D. Liang 6.5 Printing distinct numbers.cDescriptionInputOutputSample InputSample Output的全部内容,希望文章能够帮你解决[Arrays]D. Liang 6.5 Printing distinct numbers.cDescriptionInputOutputSample InputSample Output所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(47)

评论列表共有 0 条评论

立即
投稿
返回
顶部