我是靠谱客的博主 优美金针菇,最近开发中收集的这篇文章主要介绍C语言Matrix编程题——[Pointers and C-String]D. Liang 7.2 Printing distinct numbers,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

[Pointers and C-String]D. Liang 7.2 Printing distinct numbers

Description:

Use pointers on array to write a program that reads in n integers and displays distinct numbers (ie., if a number appears multiple times, it is displayed only once).

Input:

The first line is a positive integer t for the number of test cases.
Each test case contains two lines. The first line is an integer n (0<n<=100).
The second line contains n integers.

Output:

For each test case, outputs the distinct numbers in order in which they were read, separated by one blank.

Sample Input:

2
3
1 2 1
4
2 1 2 1

Sample Output:

1 2
2 1

Programme:

//Date:2020/5/8
//Author:Kamenrider Justice
#include<stdio.h>
int main()
{
int n,i,j,k,num;//n是运行的次数,num是输入的个数
scanf("%d",&n);
int number[100];//储存输入的数
int flag;
//判断是否有重复的数 
for(i=0;i<n;i++)
{
scanf("%d",&num);
for(j=0;j<num;j++)//储存数到数组
{
scanf("%d ",&number[j]);
}
printf("%d",number[0]);
for(j=1;j<num;j++)
{
flag=1;//使flag回到初始状态
for(k=0;k<j;k++)
{
if(*(number+j)==*(number+k))
{
flag=0;
}
}
if(flag)//如果没有重复的就输出,可保证顺序和输入时一致
{
printf(" %d",number[j]);
}
}
printf("n");
}
return 0;
}

Redis 面试精讲

最后

以上就是优美金针菇为你收集整理的C语言Matrix编程题——[Pointers and C-String]D. Liang 7.2 Printing distinct numbers的全部内容,希望文章能够帮你解决C语言Matrix编程题——[Pointers and C-String]D. Liang 7.2 Printing distinct numbers所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(62)

评论列表共有 0 条评论

立即
投稿
返回
顶部