概述
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
#include<stdio.h>
#include<string.h>
int vis[1001010];
int n, k;
struct node
{
int x;
int step;
}q[1001010];
int bfs()
{
int i, head, tail;
struct node now, next;
head=0;
tail=0;
q[tail].x = n;
q[tail].step = 0;
tail++;
vis[n] = 1;
while(head < tail)
{
now = q[head];
head++;
for(i=0; i<3; i++)
{
if(i==0)
next.x=now.x-1;
else if(i == 1)
next.x = now.x +1;
else
next.x=2*now.x;
if(next.x<0|| next.x >=1001010)
continue;
if(!vis[next.x])
{
vis[next.x] = 1;
next.step = now.step + 1;
q[tail].x = next.x;
q[tail].step = next.step;
tail ++;
if(next.x == k)
return next.step;
}
}
}
}
int main()
{
while(~scanf("%d%d", &n,&k))
{
memset(vis, 0, sizeof(vis));
if(n >= k)
printf("%dn", n-k);
else
printf("%dn", bfs());
}
return 0;
}
题意 已知牛和人的位置,人单位时间只能左或右走一步,或者走现在的两倍距离(在数轴上,且牛不动),问什么时候能追上 牛
思路 广搜题 一直往深处走,直到找到解或者走不下去为止
最后
以上就是等待吐司为你收集整理的ayit第十四周训练题d题的全部内容,希望文章能够帮你解决ayit第十四周训练题d题所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复