概述
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 82618 | Accepted: 25955 |
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Output
Sample Input
5 17
Sample Output
4
Hint
Source
题目意思:
解题思路:
#include <iostream>
#include <cstring>
#include <cstdio>
#include<queue>
using namespace std;
const int maxn=3000000;
int n,k;
int ans=0;
bool vis[maxn];//记录是否访问
int pace[maxn];//记录走过的所有位置
int head,pos;//当前位置和要走到的位置
queue <int> q;
int bfs()
{
q.push(n);
while(!q.empty())
{
head=q.front();
q.pop();
for(int i=0; i<3; ++i)//有三种走法
{
if(i==0) pos=head-1;//后退一步
else if(i==1) pos=head+1;//前进一步
else pos=head*2;//二倍步数
if(pos<0||pos>100000) continue;//超过范围
if(vis[pos]==false)//未访问过就加入队列
{
q.push(pos);
pace[pos]=pace[head]+1;//记录到达当前位置走过多少步
//cout<<pos<<endl;
vis[pos]=true;
}
if(pos==k) return pace[pos];//找到奶牛
}
}
}
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
while(cin>>n>>k)//农夫、奶牛位置
{
memset(vis,false,sizeof(vis));
if(n>=k) cout<<n-k<<endl;//如果比目标点远,就只能一步步后退挪回来
else cout<<bfs()<<endl;
}
return 0;
}
/*
5 17
*/
最后
以上就是踏实期待为你收集整理的POJ 3278-Catch That Cow(BFS-一维广搜)的全部内容,希望文章能够帮你解决POJ 3278-Catch That Cow(BFS-一维广搜)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复