我是靠谱客的博主 踏实期待,最近开发中收集的这篇文章主要介绍POJ 3278-Catch That Cow(BFS-一维广搜),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 82618 Accepted: 25955

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

题目意思:

在一维坐标上,奶牛丢在了K位置,农夫从N位置去找牛。
农夫只能有三种走法:①后退一步;②前进一步;③瞬移到二倍N的位置。
每次使用一种走法花费一分钟,求找到牛要花多久。

解题思路:

BFS,分别对三种走法广搜,记录走到当前位置花费多长时间,直到N==K。

#include <iostream>
#include <cstring>
#include <cstdio>
#include<queue>
using namespace std;
const int maxn=3000000;
int n,k;
int ans=0;
bool vis[maxn];//记录是否访问
int pace[maxn];//记录走过的所有位置
int head,pos;//当前位置和要走到的位置
queue <int> q;
int bfs()
{
q.push(n);
while(!q.empty())
{
head=q.front();
q.pop();
for(int i=0; i<3; ++i)//有三种走法
{
if(i==0) pos=head-1;//后退一步
else if(i==1) pos=head+1;//前进一步
else pos=head*2;//二倍步数
if(pos<0||pos>100000) continue;//超过范围
if(vis[pos]==false)//未访问过就加入队列
{
q.push(pos);
pace[pos]=pace[head]+1;//记录到达当前位置走过多少步
//cout<<pos<<endl;
vis[pos]=true;
}
if(pos==k) return pace[pos];//找到奶牛
}
}
}
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
while(cin>>n>>k)//农夫、奶牛位置
{
memset(vis,false,sizeof(vis));
if(n>=k) cout<<n-k<<endl;//如果比目标点远,就只能一步步后退挪回来
else cout<<bfs()<<endl;
}
return 0;
}
/*
5 17
*/


最后

以上就是踏实期待为你收集整理的POJ 3278-Catch That Cow(BFS-一维广搜)的全部内容,希望文章能够帮你解决POJ 3278-Catch That Cow(BFS-一维广搜)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(42)

评论列表共有 0 条评论

立即
投稿
返回
顶部