我是靠谱客的博主 能干热狗,最近开发中收集的这篇文章主要介绍poj 3278 Catch That Cow,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17
Sample Output

4
Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

入门bfs题目。

一看题目就是一道bfs的题,可是这道题不是单纯的bfs,有坐标还有步数,所以说我们要设一个结构体,存储步数和坐标。因为有三种状态,所以我们要设置一个循环来遍历三种状态,若坐标没有走过,并且在区间里,将这个节点推入队列中。

#include <iostream>
#include<queue>
#include <algorithm>
#include <cstring>
#include <cstdio>
typedef long long ll;
using namespace std;
const int maxn = 100000 + 10;
int n,k;
struct node{
int x,step;
};
queue<node> q;
int vis[maxn];
int main(){
scanf("%d%d",&n,&k);
node next,now;
q.push(node{n,0});
while(!q.empty()){
now=q.front();
q.pop();
if(now.x==k){
cout << now.step;
break;
}
for(int i=0;i<=2;i++){
if(i==0) next.x=now.x-1;
else if(i==1) next.x=now.x+1;
else if(i==2) next.x=now.x*2;
if(!vis[next.x]&&next.x>=0&&next.x<=100000){
vis[next.x]=1;
next.step=now.step+1;
q.push(next);
}
}
}
return 0;
}

最后

以上就是能干热狗为你收集整理的poj 3278 Catch That Cow的全部内容,希望文章能够帮你解决poj 3278 Catch That Cow所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(62)

评论列表共有 0 条评论

立即
投稿
返回
顶部