概述
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
#include<iostream>
#include<cmath>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<set>
#include<map>
#include<vector>
#include<string>
using namespace std;
typedef long long ll;
int vis[100001]={0};
int n,m;
void bfs(int start)
{
queue<int>q;
q.push(start);
int head;
while(!q.empty())
{
head = q.front();
q.pop();
if(head == m)
{
break;
}
if(head>0&&!vis[head-1])
{
int New = head-1;
vis[New] = vis[head]+1;
q.push(New);
}
if(head<m&&!vis[head+1])
{
int New = head+1;
vis[New] = vis[head]+1;
q.push(New);
}
if(2*head<100001&&!vis[2*head])
{
int New = 2*head;
vis[New] = vis[head]+1;
q.push(New);
}
}
}
int main(){
while(cin>>n>>m)
{
memset(vis,0,sizeof(vis));
bfs(n);
cout<<vis[m]<<endl;
}
}
最后
以上就是冷酷绿草为你收集整理的Catch That Cow的全部内容,希望文章能够帮你解决Catch That Cow所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复