概述
Catch That Cow
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a pointN (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the pointsX - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Sample Input
5 17
Sample Output
4
Hint
题意:
已知牛和人的位置,人单位时间只能左或右走一步,或者走现在的两倍距离(在数轴上,且牛不动),问什么时候能追上牛。广搜解决
代码:
//所有情况搜索
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#define maxn 100002
using namespace std;
int n,m;
struct data{
int x,step;
}p;
int vis[100005];
void bfs(){
queue<data>q;
p.x=n;
p.step=0;
q.push(p);
vis[n]=1;
while(!q.empty()){
p=q.front();
q.pop();
if(p.x==m){
printf("%dn",p.step);
return ;
}
data k=p;
if(k.x+1<maxn&&!vis[k.x+1]){
k.x++;
vis[k.x]=1;
k.step++;
q.push(k);
}
k=p;
if(k.x-1>=0&&!vis[k.x-1]){
k.x--;
vis[k.x]=1;
k.step++;
q.push(k);
}
k=p;
if(k.x*2<maxn&&!vis[k.x*2]){
k.x*=2;
vis[k.x]=1;
k.step++;
q.push(k);
}
}
}
int main(){
scanf("%d%d",&n,&m);
memset(vis,0,sizeof(vis));
bfs();
return 0;
}
最后
以上就是稳重乌龟为你收集整理的POJ - 3278 Catch That Cow的全部内容,希望文章能够帮你解决POJ - 3278 Catch That Cow所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复