我是靠谱客的博主 单身裙子,最近开发中收集的这篇文章主要介绍Catch That Cow(bfs),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers:  N and  K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4

AC代码:

        

#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int N = 200010;
int s,g;
int visited[N];
struct Step
{
int x;//位置
int step;//步数
};
queue<Step> Q;
void bfs()
{
int X, STEP;
while(!Q.empty())
{
Step tmp = Q.front();
Q.pop();
X = tmp.x;
STEP = tmp.step;
if(X == g)
{
printf("%dn",STEP);
return ;
}
if(X>0 && !visited[X - 1]) //要保证减1后有意义,所以要X > 0
{
Step temp;
visited[X-1] = 1;
temp.x = X - 1;
temp.step = STEP + 1;
Q.push(temp);
}
if(X<=g && !visited[X + 1])
{
Step temp;
visited[X + 1] = 1;
temp.x = X + 1;
temp.step = STEP + 1;
Q.push(temp);
}
if(X<=g && !visited[X * 2])
{
Step temp;
visited[X * 2] = 1;
temp.x = 2*X;
temp.step = STEP + 1;
Q.push(temp);
}
}
}
int main ()
{
while(cin>>s>>g)
{
memset(visited,0,sizeof(visited));
Step tem;
tem.x=s;
tem.step=0;
Q.push(tem);
visited[s]=1;
bfs();
}
return 0;
}
主要思路借鉴慕课郭炜老师。

最后

以上就是单身裙子为你收集整理的Catch That Cow(bfs)的全部内容,希望文章能够帮你解决Catch That Cow(bfs)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(71)

评论列表共有 0 条评论

立即
投稿
返回
顶部