我是靠谱客的博主 忧心豌豆,最近开发中收集的这篇文章主要介绍poj1083,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Moving Tables
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20685 Accepted: 6802

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

Source

Taejon 2001
即求有多少桌子不能同时移动。
#include<iostream>
#include<algorithm>
using namespace std;
int from[200];
int to[200];
int room[401];

int main(void) {
    int t;
    cin >> t;
    while (t--) {
        memset(room, 0, sizeof (room));
        int tables;
        cin >> tables;
        for (int i = 0; i < tables; i++) {
            cin >> from[i] >> to[i];
            if (from[i] > to[i]) {
                int tmp = from[i];
                from[i] = to[i];
                to[i] = tmp;//刚开始写成了to[i]=from[i],wa一次
            }
            if (from[i] % 2)//如果是房间号是奇数变为相对的偶数房间号
                from[i]++;
            if (to[i] % 2)
                to[i]++;
            for (int j = from[i]; j <= to[i]; j += 2)
                room[j]++;
        }
        sort(room, room + 401);
        cout << room[400]*10 << endl;//
    }
    return 0;
}


最后

以上就是忧心豌豆为你收集整理的poj1083的全部内容,希望文章能够帮你解决poj1083所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(41)

评论列表共有 0 条评论

立即
投稿
返回
顶部