我是靠谱客的博主 无私秋天,最近开发中收集的这篇文章主要介绍poj2593 Max Sequence(求两个不相交最大字段和),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

题目链接:http://poj.org/problem?id=2593

Description

Give you N integers a1, a2 ... aN (|ai| <=1000, 1 <= i <= N). 


You should output S. 

Input

The input will consist of several test cases. For each test case, one integer N (2 <= N <= 100000) is given in the first line. Second line contains N integers. The input is terminated by a single line with N = 0.

Output

For each test of the input, print a line containing S.

Sample Input

5
-5 9 -5 11 20
0

Sample Output

40

 思想: 对于数据a[],从左向右依次求解以a[i]结尾的最大子段和b[i],
  然后,从右向左遍历,求a[i]右边(包括a[i])的最大子段和sum,输出sum+b[i-1]的  最大值。

代码如下:

#include <iostream>
using namespace std;
#define INF 0x3fffffff
#define M 100000+17
int a[M],b[M];
int main()
{
	int n,i;
	while(cin >> n && n)
	{
		int sum = 0, MAX = -INF;
		for(i = 1; i <= n; i++)
		{
			cin >> a[i];
			sum+=a[i];
			if(sum > MAX)
			{
				MAX = sum;
			}
			b[i] = MAX;
			if(sum < 0)
			{
				sum = 0;
			}
		}
		MAX = -INF;
		sum = 0;
		int ans = MAX, t;
		for(i = n; i > 1; i--)
		{
			sum+=a[i];
			if(sum > MAX)
			{
				MAX = sum;
			}
			t = MAX + b[i-1];
			if(t > ans)
			{
				ans = t;
			}
			if(sum < 0)
			{
				sum = 0;
			}
		}
		cout<<ans<<endl;
	}
	return 0;
}

最后

以上就是无私秋天为你收集整理的poj2593 Max Sequence(求两个不相交最大字段和)的全部内容,希望文章能够帮你解决poj2593 Max Sequence(求两个不相交最大字段和)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(45)

评论列表共有 0 条评论

立即
投稿
返回
顶部