我是靠谱客的博主 帅气盼望,最近开发中收集的这篇文章主要介绍HDU 2689,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Sort it

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3379    Accepted Submission(s): 2446

Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
 
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
 
Output
For each case, output the minimum times need to sort it in ascending order on a single line.
 
Sample Input
3
1 2 3

4 3 2 1 
 
Sample Output
0

6

//这题求得是逆序数 冒泡也也行

#include <stdio.h>
#include <cstring>
int n,c[10010];
int lowbit(int x)
{
    return x&(-x);
}

void add(int i,int x)
{
    while(i<=n)
    {
        c[i]+=x;
        i+=lowbit(i);
    }
}

int sum(int i)
{
    int sum=0;
    while(i)
    {
        sum+=c[i];
        i-=lowbit(i);
    }
    return sum;
}

int main()
{
    while(~scanf("%d",&n))
    {
        int a,s=0;
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a);
            add(a,1);
            s+=i-sum(a);
        }
        printf("%dn",s);
    }


    return 0;
}


最后

以上就是帅气盼望为你收集整理的HDU 2689的全部内容,希望文章能够帮你解决HDU 2689所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(42)

评论列表共有 0 条评论

立即
投稿
返回
顶部