我是靠谱客的博主 忧虑方盒,最近开发中收集的这篇文章主要介绍NYOJ - sort it,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Sort it

时间限制: 1000 ms  |           内存限制: 65535 KB
难度: 2
描述
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
输入
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
输出
For each case, output the minimum times need to sort it in ascending order on a single line.
样例输入
3
1 2 3
4 
4 3 2 1 
样例输出
0
6
#include <stdio.h>

int sort_count(int a[], int n)      // 冒泡排序 
{
	int count = 0;
	for(int i = 0; i < n-1; i++)
	{
		for(int j = 0; j < n-1-i; j++)
		{
			if(a[j] > a[j+1])
			{
				int t = a[j];
				a[j] = a[j+1];
				a[j+1] = t;
				count++;
			}
		}
	}
	return count;
}
int main()
{
	int n,a[1000];
	while(scanf("%d",&n) != EOF)
	{
		for(int i = 0; i < n; i++)
		{
			scanf("%d",&a[i]);
		}
		printf("%dn",sort_count(a,n));
	}
}

最后

以上就是忧虑方盒为你收集整理的NYOJ - sort it的全部内容,希望文章能够帮你解决NYOJ - sort it所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(42)

评论列表共有 0 条评论

立即
投稿
返回
顶部