我是靠谱客的博主 迅速黑猫,最近开发中收集的这篇文章主要介绍Poj2259 Team Queue 多b队列做法详解,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Team Queue

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5880 Accepted: 1985

Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example. 

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue. 

Your task is to write a program that simulates such a team queue.

Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements. 
Finally, a list of commands follows. There are three different kinds of commands: 
  • ENQUEUE x - enter element x into the team queue 
  • DEQUEUE - process the first element and remove it from the queue 
  • STOP - end of test case

The input will be terminated by a value of 0 for t. 
Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one. 

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

算法分析:

  1. 暴力解法:数组直接暴力,每次找队友O(n),数组调整O(n),需要做n次,以上为最坏情况复杂度,最终复杂度约为以上相乘,无法接受。
  2. 暴力优化:不解释链表。
  3. 正解:为每个小组建立一个队列q[MAXteams],再建立一个存储所有小组的队列q_all,如果q_all中有当前小组,就在对应小组队列q[team]后插入该值,若没有该小组,就在q_all中插入该小组后,再在q[team]中插入该值。dequeue时,先取出q_all队头元素pos,再取出q[pos]队头并弹出,若弹出后队列空了,就把该小组pos从q_all中弹出。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<string>
#include<iostream>
#include<map>
using namespace std;
const int MAXteams = 1002;
int members[999999+1];
char commands[25];
int main()
{
	int teams,cnt=1;
	while(1)
	{	
		scanf("%d",&teams);
		if(teams==0)break;
		queue<int>q_all;
		queue<int>q[MAXteams];
		for(int i=1;i<=teams;i++)
		{
			int team_size,member;
			scanf("%d",&team_size);
			for(int j=1;j<=team_size;j++)
			{
				scanf("%d",&member);
				members[member]=i;//因为数据范围是0~999999,所以类似于 桶 直接存下来就好,不需要map映射。
			}
		}
		char ch=getchar();//多读一个空格,没有实际意义
		printf("Scenario #%dn",cnt);
		cnt++;
		while(true)
		{
			scanf("%s",commands);
			char op=commands[0];
			if(op=='E')
			{		
				int val;scanf("%d",&val);
				if(q[members[val]].empty())//判断是否有一个组的只需要判断改组的队列是不是空的就行
				{
					q_all.push(members[val]);
					q[members[val]].push(val);
				}
				else 
				{
					q[members[val]].push(val);
				}

			}
			else if(op=='D')
			{	
				int pos=q_all.front();
				int val=q[pos].front();
				q[pos].pop();
				printf("%dn",val);
				if(q[pos].empty())
					q_all.pop();
			}
			else break;
		}
		puts("");
	}
	return 0;
}

最后

以上就是迅速黑猫为你收集整理的Poj2259 Team Queue 多b队列做法详解的全部内容,希望文章能够帮你解决Poj2259 Team Queue 多b队列做法详解所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(70)

评论列表共有 0 条评论

立即
投稿
返回
顶部