我是靠谱客的博主 干净身影,最近开发中收集的这篇文章主要介绍poj 3660 Cow Contest(最短路floyd),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

题意:问我们能确定的牛的等级的个数,如果一个牛可以打败x个,被y个打败,当x+y=n-1时,就可以确定这个牛的等级了,因为要看所有牛之间能否联通或被联通,所有用floyd算法判断。

Cow ContestTime Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Submit Status Practice POJ 3660

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2
AC代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<queue>
#include<map>
#include<set>
#define INF 100005
#define LL long long
#define mod 1000003
using namespace std;
int n, m;
int d[105][105];
int main()
{
while (scanf("%d%d", &n, &m) != EOF)
{
int a, b;
for (int i = 1; i <= n; i++)
for (int j = 1; j <= n; j++)
d[i][j] = INF;
for (int i = 0; i < m; i++)
{
scanf("%d%d", &a, &b);
d[a][b]= 1;
}
for (int k = 1; k <= n; k++)
for (int i = 0; i <= n; i++)
for (int j = 0; j <= n; j++)
d[i][j] = min(d[i][j], d[i][k] + d[k][j]);
int k=0;
for (int i = 1; i <= n; i++)
{
int f = 0;
for (int j = 1; j <= n; j++)
{
if (d[i][j] <INF||d[j][i]<INF)
{
f++;
}
}
if (f == n-1)
{
k++;
}
}
printf("%dn", k);
}
}


最后

以上就是干净身影为你收集整理的poj 3660 Cow Contest(最短路floyd)的全部内容,希望文章能够帮你解决poj 3660 Cow Contest(最短路floyd)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(31)

评论列表共有 0 条评论

立即
投稿
返回
顶部