我是靠谱客的博主 悲凉发卡,最近开发中收集的这篇文章主要介绍POJ-3122 Pie,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Pie
Time Limit: 1000MS Memory Limit: 65536K  
    Special Judge

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Source

Northwestern Europe 2006

————————————————————冲动的分割线————————————————————

思路:该题教会我两件事,非常重要的两件事!

1.二分法不只可以对整数,还可以对浮点数

2.二分法不一定要用while(l <= r)来控制,还可以主观控制二分次数,保证精度

3.在G++编译环境当中,printf()中必须全部用"%f"来输出!不能用"%lf"!

额。。。好吧,三件事!

思路不再赘述,参考POJ Drying

代码如下:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
const double PI = 3.1415926535898;//PI必须足够精度
double area[10005];
int n, guy;
bool check(double m) {
    int man = 0;
    for(int i = 0; i < n; i++) {
        if(area[i] < m) continue;//该饼足够所有人吃
        else {
            int tmp = (int)(area[i] / m);//该饼能分给多少人
            if(tmp >= guy)  return true;
            man += tmp;
            if(man >= guy)  return true;
        }
    }
    return false;
}
int main() {
    int cas;
    scanf("%d", &cas);
    while(cas--) {
        int pie;
        scanf("%d%d", &n, &guy);
        guy++;
        double maxi = 0;
        for(int i = 0; i < n; i++) {
            scanf("%d", &pie);
            area[i] = PI * pie * pie;
            if(area[i] > maxi)
                maxi = area[i];
        }
        double l = 0, r = maxi, mid;
        int cnt = 50;
        while(cnt--) {//二分50次,精度范围2^50
            mid = (l+r) / 2;
            if(check(mid))  l = mid;//注意哦!浮点数是连续的,不能突然加上或者减去几
            else            r = mid;
        }
        printf("%.4fn", mid);//千万要写成%f
    }
	return 0;
}


最后

以上就是悲凉发卡为你收集整理的POJ-3122 Pie的全部内容,希望文章能够帮你解决POJ-3122 Pie所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(46)

评论列表共有 0 条评论

立即
投稿
返回
顶部