我是靠谱客的博主 忧伤小鸽子,最近开发中收集的这篇文章主要介绍kuangbin带你飞专题5 并查集 B - The Suspects POJ - 1611,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题意;

SARS病毒会传播,0号学生是SARS病毒嫌疑携带者。

给你m个朋友圈,n个学生。

m行,关系。

输出病毒嫌疑携带者,即与0号有关系的学生个数。

思路:

直接并上每个朋友圈的朋友,最后查一遍是否与1有关系。

 

也可以记录每个集合的个数,最后输出1所在集合的个数。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
using namespace std;
const int M = 30000+100;
int fa[M];
bool vis[M];
int get(int x)
{
	if(x==fa[x])return x;
	return fa[x]=get(fa[x]);
}
void merge(int x,int y)
{
	fa[get(x)]=get(y);
}
int main()
{
	ios::sync_with_stdio(false);
  	cin.tie(0);
  	int n,m;
  	while(cin>>n>>m&&n!=0)
  	{
  		for(int i=0;i<n;i++)fa[i]=i;
  		for(int i=1;i<=m;i++)
  		{
  			int k,x,y;
  			cin>>k;
  			cin>>x;
  			for(int j=2;j<=k;j++)
  			{
  				cin>>y;
  				merge(x,y);
			}
		}
		int yy=get(0),cnt=0;
		for(int i=0;i<n;i++)
		{
			if(get(i)==yy)
			cnt++;
		}
		cout<<cnt<<endl;
	}	
	return 0;
}

 

最后

以上就是忧伤小鸽子为你收集整理的kuangbin带你飞专题5 并查集 B - The Suspects POJ - 1611的全部内容,希望文章能够帮你解决kuangbin带你飞专题5 并查集 B - The Suspects POJ - 1611所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(45)

评论列表共有 0 条评论

立即
投稿
返回
顶部