我是靠谱客的博主 难过往事,这篇文章主要介绍poj 1611 The Suspects(并查集),现在分享给大家,希望可以做个参考。

解题思路---->显然并查集了。并查集的详细解释在可以点击 并查集(不相交集合)进行学习。采用num[]存储该集合中元素个数,并在集合合并时更新num[]即可。然后找出0所在的集合的根节点x,因此,num[x]就是answer了。

题目:

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
AC代码:

#include <iostream>
#include<cstdio>
using namespace std;

const int MAXN = 30005; /*结点数目上线*/
int pa[MAXN];    /*p[x]表示x的父节点*/
int ran[MAXN];  /*rank[x]是x的高度的一个上界*/
int sum[MAXN];

void make_set(int x)
{/*创建一个单元集*/
	pa[x] = x;
	ran[x] = 0;
	sum[x] = 1;
}

int find_set(int x)
{/*带路径压缩的查找*/
	if (x != pa[x])
		pa[x] = find_set(pa[x]);
	return pa[x];
}

/*按秩合并x,y所在的集合*/
void union_set(int x, int y)
{
	x = find_set(x);
	y = find_set(y);
	if (x == y)return;
	if (ran[x] > ran[y])/*让rank比较高的作为父结点*/
	{
		pa[y] = x;
		sum[x] += sum[y];
	}
	else
	{
		pa[x] = y;
		if (ran[x] == ran[y])
			ran[y]++;
		sum[y] += sum[x];
	}
}
int main()
{
	int n, m;
	while (scanf("%d %d", &n, &m) != EOF)
	{
		if (n == 0 && m == 0)
			break;
		if (m == 0)
		{
			printf("%dn", 1);
			continue;
		}
		for (int i = 0;i < n;i++)
			make_set(i);
		for (int i = 0;i < m;i++)
		{
			int k;
			int a, b;
			scanf("%d", &k);
			scanf("%d", &a);
			for (int j = 1;j < k;j++)
			{
				scanf("%d", &b);
				union_set(a, b);
			}
		}
		int a = find_set(0);
		printf("%dn", sum[a]);
	}
}


最后

以上就是难过往事最近收集整理的关于poj 1611 The Suspects(并查集)的全部内容,更多相关poj内容请搜索靠谱客的其他文章。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(44)

评论列表共有 0 条评论

立即
投稿
返回
顶部