概述
Time Limit: 1000MS
Memory Limit: 20000K
Total Submissions: 53051
Accepted: 25240
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
问题链接:https://vjudge.net/problem/10536/origin
问题简述:多组学生,组内学生直接交往密切,当组内有学生带‘0’,则其可能为非典携带者,且其组内学生也被认为是嫌疑人,被认为是非典携带者的人需要隔离起来。任务是求多少人需要被隔离。
问题分析:并查集
程序分析:查找‘0’的最终父节点,并输出该最终父节点所联合的人数total[find_set(0)];
ac代码如下
#include<iostream>
using namespace std;
int arr[50000];
int total[100000];
void make_set(int x)
{
arr[x] = x;
total[x] = 1;
}
int find_set(int x)
{
if (arr[x] != x)
arr[x] = find_set(arr[x]);
return arr[x];
}
void union_set(int x, int y)
{
int a = find_set(x);
int b = find_set(y);
if (a == b)
return;
else
{
arr[b] = a;
total[a] += total[b];
}
}
int main()
{
int n, m, k, x, y;
cin >> n >> m;
for (int i = 0; i < n; i++)
make_set(i);
while (m--)
{
cin >> k;
cin >> x;
while (--k)
{
cin >> y;
union_set(x,y);
}
}
cout << total[find_set(0)] << endl;
}
最后
以上就是羞涩苗条为你收集整理的# The Suspects (并查集)的全部内容,希望文章能够帮你解决# The Suspects (并查集)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复