我是靠谱客的博主 无情发带,最近开发中收集的这篇文章主要介绍The Suspects --并查集水题,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1

1

分析:并查集很水的一道题。。就是从0开始根据学生所在的组织进行合并就好了,然后累加每个集合的值。

上代码:

#include <cstdio>  
#include <cstring>  
#include <algorithm>  
#define maxn 33000  
using namespace std;  
  
int per[maxn], num[maxn], n, m;  
int a[maxn];  
  
void init(){  
    for(int i = 0; i < n ; ++i){  
        per[i] = i;  
        num[i] = 1;//一开始每个父节点所在的集合只有一个人
    }  
    return ;  
}  
  
int find(int x){  
    if(x == per[x])  
        return x;  
    return per[x] = find(per[x]);  
}  
  
void join(int x, int y){  
    int fx = find(x);  
    int fy = find(y);  
    if(fx != fy){  
        per[fx] = fy;  
        num[fy] += num[fx];//将子节点纳入父节点  
    }  
    return ;  
}  
  
int main (){  
    while(scanf("%d%d", &n, &m), n || m){  
            init();  
        while(m--){  
            int t;  
            scanf("%d", &t);  
            for(int i = 0; i < t; ++i){  
                scanf("%d", &a[i]);  
            }  
            for(int i = 0 ; i < t - 1; ++i)  
                join(a[i], a[i + 1]);  
        }  
        int  k = find(0);  //0号开始是嫌疑人
        printf("%dn", num[k]);//最后父节点的集合总人数即总的人数  
    }  
    return 0;  
}  

实在是很水,没什么好说的,差不多模板题吧。。。

最后

以上就是无情发带为你收集整理的The Suspects --并查集水题的全部内容,希望文章能够帮你解决The Suspects --并查集水题所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(66)

评论列表共有 0 条评论

立即
投稿
返回
顶部