我是靠谱客的博主 贪玩哈密瓜,最近开发中收集的这篇文章主要介绍UVALive - 3882 And Then There Was One(ac,但想不通),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

And Then There Was One
Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

Submit Status

Description

download as pdf

Let's play a stone removing game.

Initially, n stones are arranged on a circle and numbered 1,..., n clockwise (Figure 1). You are also given two numbers k and m . From this state, remove stones one by one following the rules explained below, until only one remains. In step 1, remove stone m . In step 2, locate the k -th next stone clockwise from m and remove it. In subsequent steps, start from the slot of the stone removed in the last step, make k hops clockwise on the remaining stones and remove the one you reach. In other words, skip (k - 1) remaining stones clockwise and remove the next one. Repeat this until only one stone is left and answer its number.

For example, the answer for the case n = 8 , k = 5 , m = 3 is 1, as shown in Figure 1.

epsfbox{p3882.eps}

Figure 1: An example game


Initial state: Eight stones are arranged on a circle.

Step 1: Stone 3 is removed since m = 3 .

Step 2: You start from the slot that was occupied by stone 3. You skip four stones 4, 5, 6 and 7 (since k = 5 ), and remove the next one, which is 8.

Step 3: You skip stones 1, 2, 4 and 5, and thus remove 6. Note that you only count stones that are still on the circle and ignore those already removed. Stone 3 is ignored in this case.

Steps 4-7: You continue until only one stone is left. Notice that in later steps when only a few stones remain, the same stone may be skipped multiple times. For example, stones 1 and 4 are skipped twice in step 7.

Final State: Finally, only one stone, 1, is on the circle. This is the final state, so the answer is 1.

Input

The input consists of multiple datasets each of which is formatted as follows.


n k m


The last dataset is followed by a line containing three zeros. Numbers in a line are separated by a single space. A dataset satisfies the following conditions.

$displaystyle le$ n $displaystyle le$10000, 1  $displaystyle le$ k $displaystyle le$10000, 1  $displaystyle le$ m $displaystyle le$ n

The number of datasets is less than 100.

Output

For each dataset, output a line containing the stone number left in the final state. No extra characters such as spaces should appear in the output.

Sample Input

8 5 3
100 9999 98
10000 10000 10000
0 0 0

Sample Output

1
93
2019

Source

Regionals 2007 >>  Asia - Tokyo



2007年亚洲区域赛东京赛区的一个题,约瑟夫问题的变形。代码很简洁,但不怎么好理解。
ac代码:
#include <iostream>
#include<cstdio>
using namespace std;
const int maxn=10000+5;
int f[maxn];


int main()
{
    int n,k,m;
    while(scanf("%d%d%d",&n,&k,&m)==3&&n)
    {
        f[1]=0;
        for(int i=2;i<=n;i++)
        f[i]=(f[i-1]+k)%i;
        int ans=(m-k+1+f[n])%n;
        if(ans<=0) ans+=n;
        printf("%dn",ans);
    }
    return 0;
}

最后

以上就是贪玩哈密瓜为你收集整理的UVALive - 3882 And Then There Was One(ac,但想不通)的全部内容,希望文章能够帮你解决UVALive - 3882 And Then There Was One(ac,但想不通)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(92)

评论列表共有 0 条评论

立即
投稿
返回
顶部