概述
Picture
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 24193 Accepted Submission(s): 12294
Problem Description
Give you the width and height of the rectangle,darw it.
Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
after each case, you should a blank line.
Sample Input
3 2
Sample Output
+---+ | | | | +---+
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner input=new Scanner(System.in);
//int c=input.nextInt();
while(input.hasNext()){
int n=input.nextInt();
int m=input.nextInt();
for (int i=0;i<m+2;i++){
if (i==0||i==m+1){
System.out.print("+");
for (int j=0;j<n;j++){
System.out.print("-");
}
System.out.println("+");
}else {
System.out.print("|");
for (int j=0;j<n;j++){
System.out.print(" ");
}
System.out.println("|");
}
}
System.out.println();
}
}
}
最后
以上就是喜悦自行车为你收集整理的HDU-ACM2052Picture的全部内容,希望文章能够帮你解决HDU-ACM2052Picture所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复