我是靠谱客的博主 安详刺猬,最近开发中收集的这篇文章主要介绍L - Picture,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Give you the width and height of the rectangle,darw it.

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
Sample Input
3 2
Sample Output
+---+
|
|
|
|
+---+


#include<stdio.h>
int main()
{
int n, m, i, j;
while(scanf("%d%d", &n, &m)!=EOF)
{
char a[99][99]={0};
a[0][0]=a[m+1][0]=a[m+1][n+1]=a[0][n+1]='+';
for(j=1;j<=n;j++)
a[0][j]=a[m+1][j]='-';
for(i=1;i<=m;i++)
a[i][0]=a[i][n+1]='|';
for(i=0;i<=m+1;i++)
{
for(j=0;j<=n+1;j++)
{
if(a[i][j])
printf("%c", a[i][j]);
else
printf(" ");
}
printf("n");
}
printf("n");
}
return 0;
}


最后

以上就是安详刺猬为你收集整理的L - Picture的全部内容,希望文章能够帮你解决L - Picture所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(35)

评论列表共有 0 条评论

立即
投稿
返回
顶部