我是靠谱客的博主 强健老虎,最近开发中收集的这篇文章主要介绍HDOJ 2052 Picture,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description
Give you the width and height of the rectangle,darw it.

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

Sample Input
3 2

Sample Output
+---+
|
|
|
|
+---+

别忘了每一个输出后面空一行

import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while(sc.hasNext()){
int m = sc.nextInt();
int n = sc.nextInt();
for(int i=0;i<n+2;i++){
for(int j=0;j<m+2;j++){
if(i==0){
if(j==0||j==m+1){
System.out.print("+");
}else{
System.out.print("-");
}
}else if(i==n+1){
if(j==0||j==m+1){
System.out.print("+");
}else{
System.out.print("-");
}
}else {
if(j==0||j==m+1){
System.out.print("|");
}else{
System.out.print(" ");
}
}
}
System.out.println();
}
System.out.println();
}
}
}

最后

以上就是强健老虎为你收集整理的HDOJ 2052 Picture的全部内容,希望文章能够帮你解决HDOJ 2052 Picture所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(39)

评论列表共有 0 条评论

立即
投稿
返回
顶部