我是靠谱客的博主 平淡萝莉,最近开发中收集的这篇文章主要介绍HDOJ--2052 Picture,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Picture

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22407    Accepted Submission(s): 11407


Problem Description
Give you the width and height of the rectangle,darw it.
 

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
 

Sample Input
3 2
 

Sample Output
+---+ | | | | +---+
 


简单的操作,以下是我的AC代码:

#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
const int MAXN=1010;
char a[MAXN][MAXN];
using namespace std;
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)==2)
{
cout<<"+";
for(int i=1;i<=n;i++)
cout<<"-";
cout<<"+"<<endl;
for(int j=1;j<=m;j++)
{
cout<<"|";
for(int i=1;i<=n;i++)
cout<<" ";
cout<<"|"<<endl;
}
cout<<"+";
for(int i=1;i<=n;i++)
cout<<"-";
cout<<"+"<<endl<<endl;;
}
return 0;
}


最后

以上就是平淡萝莉为你收集整理的HDOJ--2052 Picture的全部内容,希望文章能够帮你解决HDOJ--2052 Picture所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(37)

评论列表共有 0 条评论

立即
投稿
返回
顶部