概述
Problem Description
Give you the width and height of the rectangle,darw it.
Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
after each case, you should a blank line.
Sample Input
3 2
Sample Output
+---+ | | | | +---+
Author
xhd
Source
校庆杯Warm Up
C语言AC代码
#include<stdio.h>
int main()
{
int i,j,n,m,a[5000];
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=0;i<=m+1;i++)
{
for(j=0;j<=n+1;j++)
{
if(i==0&&j==0||i==m+1&&j==0||i==0&&j==n+1||i==m+1&&j==n+1)
printf("+");
else if((j==0&&i>0&&i<m+1||j==n+1&&i>0&&i<m+1))
printf("|");
else if(i==0&&j>0&&j<n+1||i==m+1&&j>0&&j<n+1)
printf("-");
else
printf(" ");
}
printf("n");
}
printf("n");
}
return 0;
}
心得:题目要绕一个矩形出来,矩形长度n*m,所以注意输出就行了,但是我做得慢了,遇到简单的题,更应当高效地解决,还是要多做题~
最后
以上就是闪闪山水为你收集整理的hdu2052 Picture(C语言)的全部内容,希望文章能够帮你解决hdu2052 Picture(C语言)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复