我是靠谱客的博主 细心画笔,最近开发中收集的这篇文章主要介绍HDOJ1323Perfection(完数)Perfection,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Perfection

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3158    Accepted Submission(s): 1934


Problem Description
From the article Number Theory in the 1994 Microsoft Encarta: "If a, b, c are integers such that a = bc, a is called a multiple of b or of c, and b or c is called a divisor or factor of a. If c is not 1/-1, b is called a proper divisor of a. Even integers, which include 0, are multiples of 2, for example, -4, 0, 2, 10; an odd integer is an integer that is not even, for example, -5, 1, 3, 9. A perfect number is a positive integer that is equal to the sum of all its positive, proper divisors; for example, 6, which equals 1 + 2 + 3, and 28, which equals 1 + 2 + 4 + 7 + 14, are perfect numbers. A positive number that is not perfect is imperfect and is deficient or abundant according to whether the sum of its positive, proper divisors is smaller or larger than the number itself. Thus, 9, with proper divisors 1, 3, is deficient; 12, with proper divisors 1, 2, 3, 4, 6, is abundant."
Given a number, determine if it is perfect, abundant, or deficient.
 

Input
A list of N positive integers (none greater than 60,000), with 1 < N < 100. A 0 will mark the end of the list.
 

Output
The first line of output should read PERFECTION OUTPUT. The next N lines of output should list for each input integer whether it is perfect, deficient, or abundant, as shown in the example below. Format counts: the echoed integers should be right justified within the first 5 spaces of the output line, followed by two blank spaces, followed by the description of the integer. The final line of output should read END OF OUTPUT.
 

Sample Input
15 28 6 56 60000 22 496 0
 

Sample Output
PERFECTION OUTPUT 15 DEFICIENT 28 PERFECT 6 PERFECT 56 ABUNDANT 60000 ABUNDANT 22 DEFICIENT 496 PERFECT END OF OUTPUT
  当i时数据n的倍数的时候,将i加起来,总和等于n的时候输出PERFECT
小于n的时候输出DEFICIENT,大于n的时候输出ABUNDANT。
我看有些人是以为这个题目有很多行,其实只有一行数据,以0结束。
import java.util.Scanner;
public class Main{
private static Scanner scanner;
public static void main(String[] args) {
scanner = new Scanner(System.in);
boolean isFirst = true;
while(scanner.hasNext()){
int n = scanner.nextInt();
if(n == 0){
break;
}
int sum = 0;
for (int i = 1; i <= n/2; i++) {
if(n%i==0){
sum+=i;
}
}
if(isFirst){
System.out.println("PERFECTION OUTPUT");
}
isFirst = false;
System.out.printf("%5d",n);
if(sum==n){
System.out.println("
PERFECT");
}else if(sum>n){
System.out.println("
ABUNDANT");
}else {
System.out.println("
DEFICIENT");
}
}
System.out.println("END OF OUTPUT");
}
}


最后

以上就是细心画笔为你收集整理的HDOJ1323Perfection(完数)Perfection的全部内容,希望文章能够帮你解决HDOJ1323Perfection(完数)Perfection所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(33)

评论列表共有 0 条评论

立即
投稿
返回
顶部