我是靠谱客的博主 忧伤季节,最近开发中收集的这篇文章主要介绍hdoj1443Joseph【约瑟夫环 打表】 Joseph,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Joseph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2109    Accepted Submission(s): 1283


Problem Description
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 
 

Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14. 
 

Output
The output file will consist of separate lines containing m corresponding to k in the input file. 
 

Sample Input
3 4 0
 

Sample Output
5 30
 

Source
ACM暑期集训队练习赛(5)
 

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<vector>
using namespace std;
int kill(int n,int k,int i){
if(i==1)
return (n+k-1)%n;
else
return (kill(n-1,k,i-1)+k)%n;
}
int f[15];
void dabiao(){
int i,m,k;
for(k=1;k<14;++k){
for(m=k;;++m){
for(i=1;i<=k;++i){
if(kill(2*k,m,i)+1<=k)break;
}
if(i>k)break;
}
f[k]=m;
}
}
int main()
{
dabiao();
int t,k,n,i,j;
while(scanf("%d",&k),k){
printf("%dn",f[k]);
}
return 0;
}


最后

以上就是忧伤季节为你收集整理的hdoj1443Joseph【约瑟夫环 打表】 Joseph的全部内容,希望文章能够帮你解决hdoj1443Joseph【约瑟夫环 打表】 Joseph所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(40)

评论列表共有 0 条评论

立即
投稿
返回
顶部