我是靠谱客的博主 安静眼睛,最近开发中收集的这篇文章主要介绍HDOJ 5154 Harry and Magical Computer floyd判环 Harry and Magical Computer,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述


 floyd判环

Harry and Magical Computer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1005    Accepted Submission(s): 404


Problem Description
In reward of being yearly outstanding magic student, Harry gets a magical computer. When the computer begins to deal with a process, it will work until the ending of the processes. One day the computer got n processes to deal with. We number the processes from 1 to n. However there are some dependencies between some processes. When there exists a dependencies (a, b), it means process b must be finished before process a. By knowing all the m dependencies, Harry wants to know if the computer can finish all the n processes.
 

Input
There are several test cases, you should process to the end of file.
For each test case, there are two numbers n m on the first line, indicates the number processes and the number of dependencies.  1n100,1m10000
The next following m lines, each line contains two numbers a b, indicates a dependencies (a, b).  1a,bn
 

Output
Output one line for each test case. 
If the computer can finish all the process print "YES" (Without quotes).
Else print "NO" (Without quotes).
 

Sample Input
3 2 3 1 2 1 3 3 3 2 2 1 1 3
 

Sample Output
YES NO
 

Source
BestCoder Round #25
 


/* ***********************************************
Author
:CKboss
Created Time
:2015年02月15日 星期日 22时23分31秒
File Name
:HDOJ5154.cpp
************************************************ */
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
using namespace std;
const int maxn=110;
const int INF=0x3f3f3f3f;
int n,m;
int g[maxn][maxn];
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(g,63,sizeof(g));
for(int i=0;i<m;i++)
{
int a,b;
scanf("%d%d",&a,&b);
g[a][b]=1;
}
for(int k=1;k<=n;k++)
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
g[i][j]=min(g[i][j],g[i][k]+g[k][j]);
bool flag=false;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(g[i][j]==g[j][i]&&g[i][j]!=INF)
{
flag=true;
break;
}
}
if(flag) break;
}
if(flag) puts("NO");
else puts("YES");
}
return 0;
}



最后

以上就是安静眼睛为你收集整理的HDOJ 5154 Harry and Magical Computer floyd判环 Harry and Magical Computer的全部内容,希望文章能够帮你解决HDOJ 5154 Harry and Magical Computer floyd判环 Harry and Magical Computer所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(44)

评论列表共有 0 条评论

立即
投稿
返回
顶部