我是靠谱客的博主 爱撒娇小甜瓜,最近开发中收集的这篇文章主要介绍HDU-5587 Array(DFS) Array,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Array

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)


Problem Description
Vicky is a magician who loves math. She has great power in copying and creating.
One day she gets an array {1}。 After that, every day she copies all the numbers in the arrays she has, and puts them into the tail of the array, with a signle '0' to separat.
Vicky wants to make difference. So every number which is made today (include the 0) will be plused by one.
Vicky wonders after 100 days, what is the sum of the first M numbers.
 

Input
There are multiple test cases.
First line contains a single integer T, means the number of test cases. (1T2103)
Next T line contains, each line contains one interger M.  (1M1016)
 

Output
For each test case,output the answer in a line.
 

Sample Input
3 1 3 5
 

Sample Output
1 4 7

题目大意:一开始有一个数列{1}。每过一天,将当天的数列复制一遍,放在数列尾,并在两个数列间用0隔开,并且将当天新产生的所有数字(包括0)全加1。经过100天后,这个数列的前M项和是多少?


通过观察数列可以发现递推公式:f(n)=2*f(n-1)+2^(n-1),n表示天数,f(n)表示第n天数列的和

本来想求出通项公式,直接算第n天的数列和,然后再通过函数递推得到最终结果,但高中数学能力已远离我,这么简单的求通项公式都能算错好几次,导致最终没时间理清递推关系式。


前n项的和由2部分组成:前day天形成的数列的和 + 剩余的 n-((1LL<<day)-1)项的和

对于剩余的n-((1LL<<day)-1)项,每项减去1,共提出n-((1LL<<day)-1),剩下的第一项为0,其余的n-((1LL<<day)-1)-1项又可以形成新的前某项,由此形成递推

【语文功底太渣,只能这样表述了】


#include <cstdio>
using namespace std;
long long dfs(long long n) {//dfs(n)返回前n项的和
if(n<=0)
return 0;
long long cur=0,day=0;//cur表示第day天产生的数列的和;day表示天数
while(n>=(1LL<<day)) {//如果剩余的项数大于等于第day+1天比第day天多出的项数,则进入循环,否则跳出循环
cur=(cur<<1)+(1LL<<day);//递推公式:f(n)=2*f(n-1)+2^(n-1),n表示天数,f(n)表示第n天数列的和
n-=1LL<<day;//剩余项数减去用掉的项数
++day;//天数+1
}
return cur+dfs(n-1)+n;//
}
int main() {
int T;
long long n;
scanf("%d",&T);
while(T--) {
scanf("%I64d",&n);
printf("%I64dn",dfs(n));
}
return 0;
}


通项公式:f(n)=(n+1)*2^(n-1)

安静下来终于理清关系了,可以替换上面的dfs函数

long long dfs(long long n) {//dfs(n)返回前n项的和
if(n<=0)
return 0;
long long day=0;//day表示天数
while(n>=(2LL<<day)-1)
++day;
n-=(1LL<<day)-1;
return day*(1LL<<(day-1))+dfs(n-1)+n;
}



官方方法: 其实 {A}_{i}Ai 为i二进制中1的个数。每次变化 {A}_{k+{2}^{i}}={A}_{k}+1Ak+2i=Ak+1 , (k(k<2^i) 不产生进位,二进制1的个数加1。然后数位dp统计前m个数二进制1的个数,计算每一位对答案的贡献。只需考虑该位填1,其高位与低位的种数即可。

暂不会,待解决……

暂不会,待解决

最后

以上就是爱撒娇小甜瓜为你收集整理的HDU-5587 Array(DFS) Array的全部内容,希望文章能够帮你解决HDU-5587 Array(DFS) Array所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(86)

评论列表共有 0 条评论

立即
投稿
返回
顶部