概述
线段树的基础题 区间更新 区间求和 不用lazy标记可能会TLE
Just a Hook
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 43022 Accepted Submission(s): 20680
Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input
1 10 2 1 5 2 5 9 3
Sample Output
Case 1: The total value of the hook is 24.
AC代码:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 100010;
struct Node{
int l, r, sum, lazy;
void updata(int val)
{
sum = (r - l + 1) * val;
lazy = val;
}
}Tree[maxn * 4];
void push_up(int k)
{
Tree[k].sum = Tree[k<<1].sum + Tree[k<<1|1].sum;
}
void push_down(int k)
{
int lazyval = Tree[k].lazy;
if(lazyval)
{
Tree[k<<1].updata(lazyval);
Tree[k<<1|1].updata(lazyval);
Tree[k].lazy = 0;
}
}
void build(int k, int l, int r)
{
Tree[k].l = l, Tree[k].r = r;
Tree[k].sum = Tree[k].lazy = 0;
if(l == r)
{
Tree[k].sum = 1;
}
else
{
int mid = (l + r) >> 1;
build(k<<1, l, mid);
build(k<<1|1, mid+1, r);
push_up(k);
}
}
void updata(int k, int l, int r, int val)
{
int L = Tree[k].l, R = Tree[k].r;
if(l <= L && R <= r)
{
Tree[k].updata(val);
}
else
{
push_down(k);
int mid = (L + R) >> 1;
if(l <= mid)
updata(k<<1,l,r,val);
if(mid < r)
updata(k<<1|1,l,r,val);
push_up(k);
}
}
int main()
{
int t;
scanf("%d",&t);
for(int i = 1; i<=t; i++)
{
int n, m;
scanf("%d %d",&n,&m);
build(1,1,n);
while(m--)
{
int l, r, val;
scanf("%d%d%d", &l, &r, &val);
updata(1,l,r,val);
}
printf("Case %d: The total value of the hook is %d.n",i, Tree[1].sum);
}
return 0;
}
最后
以上就是清新黑裤为你收集整理的杭电oj Just a Hook 线段树基础题线段树的基础题 区间更新 区间求和 不用lazy标记可能会TLEJust a Hook的全部内容,希望文章能够帮你解决杭电oj Just a Hook 线段树基础题线段树的基础题 区间更新 区间求和 不用lazy标记可能会TLEJust a Hook所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复