概述
Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23401 Accepted Submission(s): 16310
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
Author
Ignatius.L
题目大概意思:给定一个n,有几种分解方法。(4=1+3和4=3+1算一种)。
这道题最开始的思路是DP。但是后来了解到母函数,这又是一个陌生的知识点。哎,关于数学方面的知识还是太少了。无论是数论还是组合数学。不说废话。
第一种方法:
转换成背包问题。由于这道题数据比较小,N最大是120。所以可以理解成120容量的背包。1-120体积的物品任意把背包装满一共有多少种方法。
状态转移公式:dp[n] = dp[n]+dp[n-j];
#include<bits/stdc++.h>
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
using namespace std ;
typedef long long ll;
typedef unsigned long long ull;
const int MAX = 125;
int dp[MAX];
int main(){
int n;
while(cin>>n){
memset(dp,0,sizeof(dp));
dp[0]=1;
for(int i = 1 ; i <= n ; i++)
for(int j = i ; j <= n ; j++){
dp[j]+=dp[j-i];
}
cout<<dp[n]<<endl;
}
return 0;
}
第二种方法:
也是使用dp的方法。
dp[i][j] :数i不超过j的分解方法数量。
dp[i][1] = 1;
i >= j
当i == j 时
dp[i][j]=dp[i][j-1]+1; (如果i==j那么其实就是比dp[i][j-1]多了一种j的分解方法)
当i > j 时
dp[i][j]=dp[i][j-1]+dp[i-j][t]; (dp[i][j]其实是在dp[i][j-1]的基础上多了j的划分。而j的划分,其实就是i-j一共有多少种分解方法。);
上述t为min(i-j,j)因为这样才能使得dp有意义。
#include<bits/stdc++.h>
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
using namespace std ;
typedef long long ll;
typedef unsigned long long ull;
const int MAX = 125;
int dp[MAX][MAX];
int main(){
int n;
while(cin>>n){
memset(dp,0,sizeof(dp));
for(int i = 1 ; i <= n ; i++)
dp[i][1] = 1 ;
for(int i = 2 ; i <= n ; i++)
for(int j = 2 ; j <= i ; j++){
if(i==j) dp[i][j] = dp[i][j-1]+1;
else{
if (i-j >= j)
dp[i][j] = dp[i][j-1]+dp[i-j][j];
else
dp[i][j] = dp[i][j-1]+dp[i-j][i-j];
}
}
cout<<dp[n][n]<<endl;
}
return 0;
}
第三种解法是母函数。也是一种常用的算法。也是这次扫盲发现的问题。由于今天还没有学习完。明天会补上。
最后
以上就是畅快裙子为你收集整理的HDOJ 1028 多种解法的全部内容,希望文章能够帮你解决HDOJ 1028 多种解法所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复